CM13-Update – „Setup Assistant stopped working“

Ich hab eben mal aus Spieltrieb mein Moto G XT1033 auf CyanogenMod 13 geflasht. Eigentlich sollte der „Dirty Flash“ von CM12.1 auf CM13 problemlos laufen, aber irgendwie bin ich nach dem Flashen der Firmware und auch der passenden Google Apps auf einen nervigen Fehler „Setup Assistant stopped working“ gestoßen, dessen Dialogbox trotz Bestätigung immer wieder aufpoppte, und so das Telefon quasi unbrauchbar macht.

Nach längerem hin und herprobieren, inklusive Formatieren von /system im TWRP bin ich drauf gestoßen, das besagtem Dienst einfach alle Rechte fehlen. Es ist etwas tricky, aber kurz nach dem Booten des Telefons kann man in die Einstellungen gehen, dort auf Apps, rechts oben auf die drei Punkte, dort auch Systemdienste anzeigen lassen und dann in der Apps-Liste den Setup Assistenten aussuchen. Im Untermenü kann man ihm dann die Rechte auf Kontakte und Telefon geben. Dann ist Ruhe mit der Fehlermeldung, und man kann das Telefon wieder benutzen.

Lediglich die eine oder andere App crasht jetzt noch, und kann mit deinstallieren und neu installieren über den Play Store wieder gangbar gemacht werden. Den „Fehler“ kannte ich aber schon aus anderen Releasewechseln her und er ist recht einfach behebbar.

Das nur als kleine Gedankenstütze, nicht zuletzt für mich selbst.

Update 28.05.2016: Im CyanogenMod-Wiki scheint es eine einfachere und auch problemlosere Fehlerbehebung zu geben.

Kommentare ( 33 )

  1. nowayback

    Ich habe dasselbe Problem. Allerdings poppt bei mir die Meldung unmittelbar nach dem Wegdrücken erneut auf, sodass es mir nicht möglich ist, auch nur die Einstellungen zu öffnen. Die Statusleiste funktioniert allerdings mit allen Apps sehr gut (liegt über dem Dialogfenster), von dort komme ich jedoch nur nicht zu den App-Einstellungen. Kann man über adb da tricksen? Die komplette UI ist durch die Popups unverwendbar geworden. (Schade, dass Google keine Wartezeit zwischen Dienst-Neustarts verwendet...)

  2. Zetrix

    ich habe es geschafft diese Einstellungen zu übernehmen in dem ich unmittelbar nach dem OK tippen für den Bruchteil der die Bedienung zulässt in die Einstellungen zu gelangen und dies auch umstellen konnte danach war die UI wieder normal zu gebrauchen. Ist halt ein wenig fummel arbeit von 15 Minuten aber machbar.

  3. feltel

    THX. Timing ist hier wirklich essentiell. ;-)

  4. mati

    Wow! Danke! Das hat mich gerettet!

  5. ti Pau

    Genial! Danke! Hat sehr geholfen.

  6. elgrande

    Perfekt, funktioniert! Danke!

  7. S3 user

    Bei mir poppt die Nachricht auf und unter Apps ist der Setup-Assistent nicht da

  8. S3 user

    Habe es gefunden

  9. nik.ka

    DU bist so ein geiler Typ!! Ich war schon ansatzweise verzweifelt :DD danke dir!!!

  10. Wurst

    Danke für den Tipp! Hat hier bei einem Samsung Galaxy S3 i9300 mit CyanogenMod 13.0 geholfen.

  11. Nickname (notwendig)

    Wo findet man den Setup-Assistenten unter S3 i9305?

  12. Odin@Frea

    Wo ist der Setup-Assistent unter S3 i9305?????

  13. Odin@S3

    Wie gelangt man zum Setup-Assistent ???

  14. saint

    Super ! Top Tip!

  15. Ano

    Hallo! Das Update vom 28.05.2016 hat mir übrigens über Umwege für mein Samsung GT-I9100 SII dann doch helfen können. Vorweg: Nach einem missglückten Update vor etwa zwei Monaten hatte ich mit unterschiedlich oft auftretenden "Google Play-Services wurden beendet" zu kämpfen. Alle "Lösungen" die ich fand, brachten mich nicht ans Ziel. Komplett neu von Null kam für mich nicht Frage. (Ist ja quasi Linux - muss eine andere Lösung geben ;) ) Und GPS lief auch nicht richtig. Kein Fix oder ewig langes Warten darauf. Nach dem Update CM13 vom 22.06.2016 kam noch der "Setup Assistent"-Fehler hinzu. Also folgte ich dem Update-Hinweis und bekam ein System, dass nach dem Starten sofort wieder automatisch herunter fuhr... :( Erneutes Aufspielen von CM und GAPPS inkl. dem Löschen von Dalvik, Cache und System brachten nun (scheinbar) den Erfolg. Keine "Play-Service"- und keine "Setup-Assistent"-Fehlermeldung mehr. Uns GPS funktioniert auch wieder! :) Vielen Dank und vielleicht hilft mein Eintrag ähnlich Leidenden. ;) Ano

  16. Hanf

    bei mir hats auch geholfen :D wollt mein Handy schon an die wand schmeißen

  17. User31052001

    Vielen Dank!!!

  18. sagei

    diese Lösung hier -> http://www.deseret-tech.com/journal/cyanogenmod-13-nightly-setupwizard-has-stopped-working/ gefiel mir besser :-) mfg

  19. DonSenilo

    Ich hatte dasselbe Problem, popups ohne Ende und kein gps. Ursache dürfte gewesen sein, dass sich mein gapps-Paket nicht flashen ließ, zu groß. Deshalb raus aus dem recovery, die mini-gapps im 2. Durchgang geflasht und genau das ist schlecht, hier http://www.cyanogenmod.org/blog/cm-13-0-release-1 steht's: "If you reboot in between CM and the extra package, you will have a bad time due to how the permissions model works in M. Reboot out of recovery only after you have flashed both packages" also alles noch einmal von vorne, cm und gapps im Hieb geflasht und alles wunderbar!

  20. Peter

    Hatte das selbe Problem auf meinem Galaxy S3. Ich habe nun über den Recovery-Modus einen factory-reset gemacht, den cache gelöscht. Danach cm-13.0-20160717-NIGHTLY-i9300.zip neu installiert und anschließend die pico-Version installiert. Also alles im Recovery-Modus direkt am Telefon: - wipe data/factory reset - wipe cache partition - install zip cm-13.0-20160717-NIGHTLY-i9300.zip - install zip open_gapps-arm-6.0-pico-20160719 Es läuft nun alles soweit ohne Problem.

  21. Gizmo

    Hallo Sebastian, Vielen Dank für deine Beschreibung des Problems, die ich nach Update meines GT9300 auf CM13 und Aktualisierung der GAPPS in gleicher Form vorfand. Man muss ziemlich schnell sein, um sich nach dem wegklicken der Fehlermeldung nach und nach immer weiter an die richtige Stelle zu navigieren und die beiden fehlenden Rechte einzutragen - aber hat man es geschafft ist der Fehler auch erledigt... Gruß Gizmo

  22. Gizmo

    Nachtrag: Weil es oben mehrfach angefragt wurde... der Setup-Assistent ist erst sichtbar, wenn man - wie von Sebastian beschrieben - durch klicken auf die drei Punkte, die Option "Systemdienste anzeigen lassen" aktiviert hat... Gruß Gizmo

  23. scnnr

    Ich habe Deine Lösung ausprobiert, hat ein paar Minuten gedauert aber jetzt geht das Telefon wieder. Sehr kool. Die Lösung von Sagei habe ich später auch gelesen. Probiere ich das nächste mal aus. Bin erstmal sehr zufrieden. SCNNR sagt DANKE!

  24. S3_Sunny

    Vielen Dank für diesen Post, konnte so mein S3 auch auf CM13 bringen. Danke!

  25. Nickname (notwendig)

    Es klappt! Ist was etwas nervig sich zum Unterpunkt hinzuhangelb, aber das ist die Lösung! Dachte schon ich müsste .... Danke!!!

  26. Floriankpunkt

    Danke für deine Tipps! Bin heute auch von cm12 auf cm13 umgestiegen und hatte natürlich das selbe Problem. Leider ließen sich bei mir die Rechte nicht ändern aufgrund von irgendwelchen Display-Overlay Einstellungen. Hab dann einfach mit einem Root-Explorer die /data/system/users/0/runtime-permissions.xml gelöscht. Nach einem Neustart war der Fehler weg. :)

  27. BobaFit

    Hey, Sebastian. Danke für deinen Tipp, hat super geklappt. Bin froh das ich nicht wieder ne ätere version von CM draum machen muss (Android 4.4) und das ich jetzt die vorteile der Rechtevergabe nutzen kann. Ist natürlich dann n bisschen blöde wenn bei den Systemapps keine Rechte vergeben wurden und dadurch einem das Leben schwer machen. ^-^ Hatte das gleiche Problem übrigens auch bei "Trebuchet". Ist die App quasi für den "Desktop" des Smartphones. Da hab ich der App einfach allen 3 die Rechte gegeben, Kontakte, Speicher und Telefon. Grüße BobaFit

  28. Sossus

    Super - vielen Dank! Du warst meine Rettung :-)

  29. MarkMH

    Hallo zusammen, habe dasselbe Problem aber leider einen schwarzen Bildschirm mit dem Setup-Fehler. Hat hier vielleicht jemand eine Lösung. Schon einmal vielen Dank.

  30. ICh

    Vielen Dank! :)

  31. kAoskAtte

    Bravo! Hat mich auch gerettet. ich habe ein Samsung Galaxy S2 und wollte mal experimentieren, ein neues Nightly ohne Google Apps zu installieren und bin so in die Falle getappt. Fehler zig mal weggeklickt und unmittelbar nach Wegklicken - bevor der Fehler nach einer halben Sekunde erneut aufpoppt - in Richtung der genannten Einstellung navigiert. Die Fehlermeldung gab Ruhe. Jetzt wird alles gesichert und das Handy neu formatiert und eingerichtet. Leider läuft CM13 nicht rund auf menem SGS2. Ich versuche es mit einer Formatierung unf Neueinrichtung. Danke für den Tipp, so dass ich meine Daten vorher noch sichern kann.

Hinterlasse eine Antwort

Deine eMail-Adresse wird nicht veröffentlicht.

Du kannst diese HTML-Tags und -Attribute verwenden::

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>